Синтаксис функций «ЕСЛИ», «И», «ИЛИ».

Синтаксис функций «ЕСЛИ», «И», «ИЛИ».

Лабораторная работа 4

Функции Excel. Логические функции

Цели работы:

1. Изучить структуру логических функций.

2. Научиться использовать их в собственных документах.

Короткие теоретические сведения

Основным инвентарем юзера при работе с электрическими таблицами являются функции. По предназначению их можно разбить на несколько групп: арифметические функции; функции округления; степенные; тригонометрические; логические; денежные; сводные; функции выбора и поиска; матричные функции Синтаксис функций «ЕСЛИ», «И», «ИЛИ». и т.д. (всего более 150 функций). Функция может быть частью сложной формулы либо представлять собой формулу.

Правила ввода функции:

  1. Ввод функцииначинается с набора имени функции русскими знаками либо ее выбора из перечня поля имени,либо при помощи меню Вставка/Функция… .
  2. За именованием в круглых скобках набираются аргументы Синтаксис функций «ЕСЛИ», «И», «ИЛИ». функций согласно синтаксису определенной функции. В неких функциях количество аргументов непостоянно. Необязательные аргументы в написании синтаксиса функции указаны в квадратных скобках.
  3. Ввод адресов и ключевиков, применяемых в функциях, можно производить как большими, так и строчными английскими знаками с клавиатуры либо при помощи мыши (щелчок на ячейке, значение которой употребляется в Синтаксис функций «ЕСЛИ», «И», «ИЛИ». формуле).
  4. Время от времени формулы могут иметь очень длиннющий, неоглядный вид. В этих случаях комфортно разбивать их на отдельные строчки снутри ячейки (как текст), используя кнопки. Левый Alt + Enter.

Логические функции позволяют строить формулы, результаты выполнения которых зависят от неких критерий. Эти условия задаются операциями отношений ( =; ; =; ) меж 2-мя операндами (слагаемыми, сомножителями Синтаксис функций «ЕСЛИ», «И», «ИЛИ»., уменьшаемым и вычитаемым и т.д.). Результатом выполнения условия является значение «истина» либо «ложь», которые определяют выбор метода вычисления результата функции.

Синтаксис функций «ЕСЛИ», «И», «ИЛИ».

1. ЕСЛИ (;;[])– функция инспектирует логическое, и если оно поистине, возвращает 1-ый итог, если неверно - 2-ой.

Примеры: =ЕСЛИ(А3= «Аня»; «девушка»; «юноша»);

=ЕСЛИ Синтаксис функций «ЕСЛИ», «И», «ИЛИ».(А1<100; «число наименее 100»; «больше либо равно 100»)

=ЕСЛИ(В7<=17,5; D15;D17).

Аргументом функции ЕСЛИ ( ) может быть другая функция (при формировании более сложных критерий). Уровень вложенности функций менее 7.

2. И(;;;….) – возвращает значение Правда, если правды все аргументы. Функция именуется функцией логического умножения.

3. Либо(;;;….) – возвращает значение Правда, если истинен хотя бы один из аргументов. Функция именуется Синтаксис функций «ЕСЛИ», «И», «ИЛИ». функцией логического сложения.

Нередко функции И(), Либо() употребляются для задания сложного условия функции ЕСЛИ(). Они по смыслу соответствуют союзам в российском языке. Особенность имеет функция Либо(): она употребляется в Excel исключительно в объединяющем смысле этого слова.

Пример: =ЕСЛИ(и(А1>0;A1<5); «число в интервале (0;5)»; если(А1<0; «число отрицательное Синтаксис функций «ЕСЛИ», «И», «ИЛИ».»; «число больше 5 либо равно 0»))

Пример 1. В ячейки А1 и А2 введены числа. В ячейке С1 написать какое из чисел больше. Итог получить как:

· выражение текстового типа;

· выражение числового типа.

Решение.

1. Формула в ячейке С1, где итог текстового типа смотрится последующим образом:


  1. Формула в ячейке С1, где итог числового типа смотрится Синтаксис функций «ЕСЛИ», «И», «ИЛИ». последующим образом: =ЕСЛИ(А1>А2; А1; А2)

Пример 2. В ячейки А1, А2, А3 введены числа. В ячейке С1 написать ответ на вопрос: «Правда ли, что значение в ячейке А1 больше других?»

Решение.

1 метод без использования логической функции: И(.)

Формула в ячейке С1 смотрится последующим образом:

=ЕСЛИ(А1>А2;ЕСЛИ Синтаксис функций «ЕСЛИ», «И», «ИЛИ».(А1>А3;«А1 самое большое»; «А1 не самое большое»); «А1 не самое большое»)

Тут 2-ая функция ЕСЛИ() является вторым аргументом первой функции ЕСЛИ().

Аргументы для наружной функции«ЕСЛИ().

2 метод с внедрением логической функции: И()

Формула в ячейке С1 смотрится последующим образом:

=ЕСЛИ(И(А1>А2;А1>А3);«А1 самое Синтаксис функций «ЕСЛИ», «И», «ИЛИ». большое»;«А1 не самое большое»)

При записи сложных критерий функция ЕСЛИ() может получиться массивной и ненаглядной. Чтоб упростить получение итогового выражения, можно использовать более понятный метод записи.

Пример 3. Записать функцию ЕСЛИ() для того, чтоб найти, что значение только одной из 2-ух ячеек А1 и А2 больше 0.

Решение.

Сформулируем Синтаксис функций «ЕСЛИ», «И», «ИЛИ». поначалу функцию словами:

Если (А1>0 и А2<0) либо (А10), то «Да», по другому «Нет».

Употребляется одна функция Либо(), аргументами которой являются значения 2-ух функций И(). Сейчас перепишем это выражение по правилам, принятым в Excel:

ЕСЛИ (Либо ( И(A1>0;A2<0) ; И(A10) ) )

Пример 4. Составить таблицу для автоматизации вычисления Синтаксис функций «ЕСЛИ», «И», «ИЛИ». размера заработка продавцов конторы.

Начальные данные: фиксированный оклад продавцов; сумма, на которую «продано» продукта; норма объема продаж; процент «премии», зависимо от объема продаж.

Правила расчета:

Если «Продано» меньше «Нормы» либо «Норма», то «Премия» = 0руб.

Если «Продано» больше «Нормы», то «Премия» = «Продано» *20%

Если «Продано» больше 2-ух «Норм», то «Премия» = «Продано» *20%+1000руб Синтаксис функций «ЕСЛИ», «И», «ИЛИ»..


sintaksicheskie-osobennosti-rechi-detej-na-materiale-rasskazov-n-n-nosova.html
sintaksicheskie-sposobi-kompressii.html
sintaksicheskij-analiz-slovosochetaniya.html